Drupal Upgrade

  • strict warning: Non-static method view::load() should not be called statically in /home1/thephan1/public_html/sites/all/modules/views/views.module on line 879.
  • strict warning: Declaration of views_handler_filter::options_validate() should be compatible with views_handler::options_validate($form, &$form_state) in /home1/thephan1/public_html/sites/all/modules/views/handlers/views_handler_filter.inc on line 589.
  • strict warning: Declaration of views_handler_filter::options_submit() should be compatible with views_handler::options_submit($form, &$form_state) in /home1/thephan1/public_html/sites/all/modules/views/handlers/views_handler_filter.inc on line 589.
  • strict warning: Declaration of views_handler_filter_boolean_operator::value_validate() should be compatible with views_handler_filter::value_validate($form, &$form_state) in /home1/thephan1/public_html/sites/all/modules/views/handlers/views_handler_filter_boolean_operator.inc on line 149.
  • strict warning: Declaration of views_plugin_row::options_validate() should be compatible with views_plugin::options_validate(&$form, &$form_state) in /home1/thephan1/public_html/sites/all/modules/views/plugins/views_plugin_row.inc on line 135.
  • strict warning: Declaration of views_plugin_row::options_submit() should be compatible with views_plugin::options_submit(&$form, &$form_state) in /home1/thephan1/public_html/sites/all/modules/views/plugins/views_plugin_row.inc on line 135.
in

I just upgraded Drupal to the latest version (5.1) and since it uses a new theme engine, I reverted to that one. It looks like it will be a lot more powerful than the old one I was using. However, I'm going to have to retheme from scratch, so it may take some time before The Inkwell looks like its old self again. (This time, though, it will be a bit smoother.) Anyway, if you have any suggestions or requests that you think would be an improvement, by all means, let me know.